Submit a request

Adding Schema.org / Rich Snippets to your products

Follow

Feature Request

Need an integration or feature that doesn't exist?

Our experienced development team is always looking to add new capabilities to the platform. Let us know what you are looking for!


Enterprise Support

Is your company in need of full time 24/7 AmeriCommerce support?

Our Enterprise support plan is the perfect fit for large operations needing the commitment of our team outside of standard operating hours.

Comments

4 comments

  • Avatar
    Brian Gluck

    Great document for the DIYer, and even better that it is automatically included for the new responsive themes you release!

    0
    Comment actions Permalink
  • Avatar
    tnovak

    I have run into issues with google and products that are a grouping or have options where google can't see either the SKU or MPN of the option items, even if I have created inventory items for them. I can't find anywhere in the code where those could be pulled from in the variant section. I'm having to create page templates for each of these types also as google has shut one of our merchant center accounts off due to incorrect prices where they were only getting the price of the parent item and not the grouped products. I think I have that issue sorted out for grouped products, but I'm still getting the Product identifiers provided but 'identifier_exists' set to false message in MC for these products. Most of our items do not have a UPC code so I have to make sure the MPN is sent to google for each product. Having them coded correctly in the template is not an easy task now since it seems as the variants are not laid out the same as grouped items. Can you give us any tips for these types of products?

    0
    Comment actions Permalink
  • Avatar
    Tony Ruiz

    Hi guys,

    I’ve been testing the schema functions in backlink building page and everything seems to be working ok, however, when I analyse it with rich results data tester, I got an Invalid URL in field warning.

    I’ve tried to follow other tutorials, turn redirection on an off, cache, plugins etc… but the warning is still there..

    I hope you can help me! thanks!

    1
    Comment actions Permalink
  • Avatar
    Kathy Sechrist

    I've had nothing but trouble from the Reviews snippets, per Google.

    I have a VERY old theme, so I decide to look at the code in a newer theme (Foundation) to see if anything in there helps me. The first thing I noticed is that the code uses data-vocabulary.org instead of schema.org. How much difference does this make? I believe Google wants schema.org.

    Has anyone had success with the default code in Foundation working with Reviews to Google's satisfaction? I might change themes just to fix this problem once and for all!

    0
    Comment actions Permalink

Please sign in to leave a comment.

We're Here To Help


Standard Support Hours: Monday-Friday 8AM-6PM CST
Looking for Premium Support? Just ask!

Speak to a live person
1 (800) 936-9006
Submit A Support Ticket
Submit Your Ticket Here